[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Date Index][Thread Index][Author Index]

Re:Help Me!!Gibson Echoplex Digital Pro

At 23:47 06/12/04, you wrote:
>When play backing, I hear the recorded material really clear but the 
>Echoplex seems to add a lot of noise/ hiss.  And I know for sure the 
>Echoplex is the cause.  I tried different cables, different guitar, no 
>effects in between,.... but it's still there.  If you hit the record 
>button and don't play anything, and then hit the record button again 
>back), it's a really really obvious and loud hiss sound.

EDP is essentially a line level device.
So if you're using it direct to guitar amp, it may be a bit hard to set 
volumes right.
...but try putting input level up till just before distortion (LED=orange) 
and turning down the Output. That should help with the noise.
Or try putting EDP in your amp's FX loop.

>Like all of this isn't enough.... I also think the undo function isn't 
>functioning properly

Your Undo is working correctly.

>.For example, I record a very short phrase and make sure the Undo LED is 
>green.  When I hit it, sometimes it gets rid of the overdub right away, 
>sometimes I have to hit it twice or even three times,

Either because Feedback wasn't on full, or
because there was a layer of something recorded over your overdub, maybe 
not loud enough to notice, but the EDP recorded it.

>or sometimes I hit it but there's still a fragment left of the overdub.

...try a Long Press of Undo to get rid of more of your overdub.

There's an explanation in the manual about Undo.
...but consider that the EDP has no way of "knowing" where your overdub 
starts and ends,
so it can't always just delete the bit you want it to.

andy butler